•  
      request #10918 Can not add member in project administration
    Infos
    #10918
    Anton KULIK (d00AK)
    2017-12-12 13:40
    2017-12-11 20:04
    11198
    Details
    Can not add member in project administration
    Current state:
    1) Removing member form project works fine.
    2) However, adding a project member fails and causes a blank page.
    3) Browser dev tools show a 500 error for a second. (response headers attached)

    Note 01): my Tuleap installation is over a year old. Hence, I'm trying to add users that are also "unix" users. This may refer to this tracker's request #10782 "Disable usage of unix users and groups" in this tracker.
    Note 02): A week ago even the search field for adding users did not work. Only after recent updates around previous Monday, the search field resumed to work. Now it finds users I want to add. The "add member" button still causes blank screen with 500 error.
    Project admin
    9.15
    CentOS 6
    • [ ] enhancement
    • [ ] internal improvement
    Empty
    Stage
    Empty
    Declined
    Empty
    Attachments
    References
    Referenced by request #10918

    Follow-ups

    User avatar
    Anton KULIK (d00AK)2017-12-12 13:30
    Hi,
    yes, I confirm that disabling and removing the LDAP plugin restored the ability to add project members.

    Thanks!

    P.S. "attach the log file directly to the artifact" -> OK.
    User avatar
    Thomas Gerbet (tgerbet)2017-12-12 13:21
    Hello,

    In the future, please do not attach screenshots of log files, just attach the log file directly to the artifact. It is far easier and usable to deal with text files than image files (and we got logs that are not truncated by the size of your screen).

    For your issue it looks like your LDAP configuration is completely broken, it looks like that at least sys_ldap_server, sys_ldap_dn, sys_ldap_uid, sys_ldap_eduid, sys_ldap_cn and sys_ldap_mail parameters are unset/not present in your /etc/tuleap/plugins/ldap/etc/ldap.inc file. Do you have the need of the LDAP plugin? If no, I'm going to suggest to disable then uninstall it.
    User avatar
    Anton KULIK (d00AK)2017-12-11 23:08
    last edited by: Anton KULIK (d00AK) 2017-12-11 23:16
    Hi Thomas,
    Tuleap version: 9.15.99.1
    the attached the httpd log has no info because I moved to nginx setup two weeks ago.
    The php-fpm log begins with two lines relating export to XML of Agile dashboard Admin (see another bug report)
    other lines LDAP.class.php probably relate to adding user issue.

    User avatar
    Thomas Gerbet (tgerbet)2017-12-11 22:45
    I just saw your screenshot: you have compromised your user account on your platform. I highly recommend you immediately change your password and ask to your site administrator to drop all existing user sessions (Administration -> All users).

    • Attachments tuleap add user fail Screen Shot 2017-12-11 at 19.55.35 .png removed
    User avatar
    Thomas Gerbet (tgerbet)2017-12-11 22:38
    Hello,

    Can you please attach to this artifact the error logs you got when try to add a new project member (either /var/opt/rh/rh-php56/log/php-fpm/error.log or /var/log/httpd/error_log)?

    Can you also give use the exact version of Tuleap you are running?

    • Status changed from New to Waiting for information
    • Is an Enhancement or an internal improvement? cleared values: internal improvement