•  
      request #12275 Upgrade Angular version to latest in Kanban, PlanningV2 and TestManagement
    Infos
    #12275
    Joris MASSON (jmasson)
    2018-09-19 16:54
    2018-09-14 16:24
    12283
    Details
    Upgrade Angular version to latest in Kanban, PlanningV2 and TestManagement
    As a Tuleap dev,
    I want to upgrade AngularJS' version to the latest up-to-date version.
    To do that, I must remove all the manual init() calls in controllers, because in AngularJS v1.5 there is a built-in callback named $onInit to serve this purpose.
    As of today, the only remaining places that do not yet make use of $onInit are the Angular Artifact Modal and the FRS plugin app.
    The FRS plugin app needs first to switch to TLP and Burning Parrot, so that's up for another request.

    This request aims to upgrade the Angular Artifact Modal, enabling us to upgrade Kanban, Planning v2 and TestManagement apps that depend on it.
    enhancement
    Other
    Empty
    Empty
    Empty
    Stage
    Empty
    Closed
    2018-09-19
    Attachments
    Empty
    References

    List of items referenced by or referencing this item.

    Artifact Tracker v5

    Follow-ups