•  
      request #13525 Fix PHP warnings of the Mediawiki plugin when running with PHP 7.3
    Infos
    #13525
    Thomas Gerbet (tgerbet)
    2019-07-18 14:26
    2019-06-24 11:07
    14559
    Details
    Fix PHP warnings of the Mediawiki plugin when running with PHP 7.3
    Spotted a few on the instances maintained by Enalean, PHPCompatibility has spotted a few more.

    Example trace:
    PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /usr/share/mediawiki-tuleap-123/languages/LanguageConverter.php on line 710
    Mediawiki
    Empty
    Empty
    • [ ] enhancement
    • [ ] internal improvement
    Empty
    Stage
    Thomas Gerbet (tgerbet)
    Closed
    2019-07-01
    Attachments
    Empty
    References
    Referencing request #13525

    Follow-ups

    User avatar
    Thomas Gerbet (tgerbet)2019-07-18 14:26
    pr #94 has been merged and the packages will be deployed with the next build (php-mediawiki-tuleap-123-1.23.9-10).
    User avatar
    Thomas Gerbet (tgerbet)2019-07-01 18:07
    PR has been merged and the packages will be deployed with the next build (php-mediawiki-tuleap-123-1.23.9-9).

    • Status changed from Under review to Closed
    • Connected artifacts
    • Close date set to 2019-07-01