•  
      request #16686 Rename tlp.dropdown to createDropdown
    Infos
    #16686
    Joris MASSON (jmasson)
    2020-09-11 12:45
    2020-09-10 18:26
    17726
    Details
    Rename tlp.dropdown to createDropdown

    follow-up of request #16129

    tlp.dropdown() is impractical. The name "dropdown" is often used to identify a dropdown instance, but the import conflicts with this usage, forcing people to most of the time rename the import import { dropdown as createDropdown }. Now that all callers use webpack, it should be possible to track usage and rename that API.

    Empty
    Empty
    Empty
    • [ ] enhancement
    • [x] internal improvement
    Empty
    Stage
    Joris MASSON (jmasson)
    Closed
    2020-09-11
    Attachments
    Empty
    References

    Follow-ups

    • User avatar
      Joris MASSON (jmasson)2020-09-11 12:45
      gerrit #20164 integrated in Tuleap 11.18.99.211

      • Status changed from Under review to Closed
      • Connected artifacts
      • Close date set to 2020-09-11
    • User avatar
      Joris MASSON (jmasson)2020-09-10 18:28
      gerrit #20164 is under review and should close this request.
      No usage has been identified in external plugins.

      • Status changed from Under implementation to Under review