Tuleap Community Edition development and releases are no longer public. You have until September 30th to download packages and sources in Tuleap project. You can contact the team if you need further assistance.

    •  
      request #7926 SVN BrowseTree error
    Infos
    #7926
    Grégory LATINIER (glatinier)
    2015-08-04 17:33
    2015-03-20 10:38
    7943
    Details
    SVN BrowseTree error
    Hi,
    I've installed Tuleap on a Centos 6.5 at Amazon AWS.
    I've added an external storage mounted at /mnt/datas

    I've changed the svnroot in the config file to /mnt/datas/repository

    My project has been correctly created, I can commit, update, checkout, see the content of each commit but I cannot browse the repository

    I've got this error :

    import viewvc File "/usr/share/viewvc/lib/viewvc.py", line 62, in import include File "/usr/share/tuleap/src/www/../utils/include.py", line 61, in load_local_config(db_include) File "/usr/share/tuleap/src/www/../utils/include.py", line 47, in load_local_config exec

    It looks like an error while loading the conf file but I couldn't have a more explicit error.

    I've tried the solution exposed here : [Tuleap-bugs] [request #7357] Blank page while browsing svn repository
    I though it was the same bug at first.

    I've removed all the comments in the file just to be sure.

    I tried changing the folder rights to 777 just in case.

    Any ideas ?
    SCM/Subversion
    Empty
    CentOS 6
    • [ ] enhancement
    • [ ] internal improvement
    Empty
    Stage
    Empty
    Closed
    2015-03-30
    Attachments
    Empty
    References
    Referencing request #7926

    Follow-ups

    User avatar
    The same error is present in Tuleap 8.4

    Solution to the problem is similar, just with another variable in file local.inc

    Variable: $sys_keep_md5_hashed_password
    Change from
    $sys_keep_md5_hashed_password = false;
    to
    $sys_keep_md5_hashed_password = 0;

    This should be fixed in:
    - code: https://github.com/Enalean/tuleap/blob/master/src/etc/local.inc.dist (appears to be fixed by request #8269, but I will still leave the comment for reference for other people that aren't able to find the request where this is fixed by "googling" the error message)
    - documentation: https://tuleap.net/doc/en/deployment-guide/intro.html#password-storage (the problematic value is mentioned in the documentation)
    User avatar
    dylan bowden (dylan)2015-03-30 10:26
    Integrated in Tuleap 7.11.99.61

    • Status changed from Under review to Closed
    • Close date set to 2015-03-30
    User avatar
    Hi Grégory,

    You should use 0 instead of 'false' in your configuration file.

    Best regards,
    Nicolas Terray
    User avatar
    I can confirm the quote problem at the end of local.inc on a brand new install on 7.11
    User avatar

    Since I can't close the bug, here is how I solved it. The last variable declaration in the local.inc I set the boolean value to 'false' instead of false. (With quotes) That solved the python error. The next error is that the script was watching the folder /svnroot of the system and mine was mapped to /mnt/datas/repository (I did change the parameter in the local.inc) To solve that I created a binding between the 2 folders.

    So to sum up I changed 

    $sys_cvs_convert_cp1252_to_utf8 = false;

    to

    $sys_cvs_convert_cp1252_to_utf8 = 'false';

    I added in /etc/fstatb

    mount -o bind /mnt/datas/repository/ /svnroot

    I hope this will help.

    Best regards