•  
      request #9202 Make Tuleap compatible with PHP 5.6
    Infos
    #9202
    Thomas Gerbet (tgerbet)
    2017-12-04 13:53
    2016-05-27 08:55
    9425
    Details
    Make Tuleap compatible with PHP 5.6

    There is a dedicated Jenkins job that tracker PHP5.6 incompatibilities:

    Overall strategy

    • For development
      • Install php 5.6 in parallel and have nginx + fpm in front
    • For production
      • Install/keep tuleap standard on centos/rhel6
      • Have a package to install all scl php56 packages (even from the deps not installed)
      • Have nginx in front reverse proxy
      • Allow to switch from php 5.3 to php 5.6

    The goal would be to progressively move pieces from php 5.3 to php 5.6 (with crafted ngnix reverse proxy rules that either redirect to apache for not converted part or to fpm to get the latest and brightest)

    For RHEL/Centos7

    • Develop packages to only depends on SCLs and not install stock php

    Todo list

    • General
      • Replace fake php scripts (src/www/users, groups, wiki/uploads, ...) by real php scripts ✓
      • SOAP
      • Access to API page
      • REST explorer
    • SVN / CVS
      • viewvc wrapper (SVN plugin, SVN core & CVS)
      • SVN proxy
    • Git
      • gitphp wrapper
      • git http wrapper
    • Mediawiki
    • Backend scripts
    • Project web pages

     

    Other
    All
    Empty
    • [ ] enhancement
    • [x] internal improvement
    Empty
    Stage
    Empty
    Closed
    2017-12-04
    Attachments
    Empty
    References
    Referencing request #9202

    Git commit

    tuleap/tuleap/stable

    Refactoring for PHP5.6 - CVS c6233c9172
    Refactoring for PHP5.6 - File Release System 7a2ffb08f6
    Remove deprecated ereg 33bf62075a
    Refactoring for PHP5.6 - My personnal page f9231b4625
    Refactoring for PHP5.6 - Help dde85b8f4b
    Refactoring for PHP5.6 - Service 430b723dbf
    Merge commit 'refs/changes/82/5782/4' of ssh://gerrit.tuleap.net:29418/tuleap into HEAD 4ce124ed46
    request #9202: php-launcher.sh try to use the PHP binary in the path. cef93c73d5
    Refactoring for PHP5.6 - Tracker V3 d86f1c6745
    Refactoring for PHP5.6 - Soap 1a240a7f92
    Merge commit 'refs/changes/92/5792/6' of ssh://gerrit.tuleap.net:29418/tuleap into stable 35a6c1a2c1
    request #9202 - Make REST tests compatible PHP5.6 d72975aaf0
    Refactoring for PHP5.6 - Document Manager 88a828814b
    Refactoring for PHP5.6 - Snippets 05fe1c8149
    Remove split usage in src/www/docman 2cdbe01906
    Remove split usages in src/www/admin 4e66a96d25
    Remove split usage in Tracker plugin 4930784cfe
    Remove split usage in Git plugin 2d9ac83cfb
    Remove split usage in src/www/file f103a08fd1
    Merge branch 'stable' into HEAD 9bb6ef4152
    Fix scalar typehint 253131d3d2
    Remove call-time pass-by-reference in graphontracker 3347af8442
    Remove $_REQUEST as function parameter f3e12a3050
    Merge commit 'refs/changes/83/6983/1' of ssh://gerrit.tuleap.net:29418/tuleap into HEAD 0e3f2c125e
    request #9202: Make Tuleap PHPWiki database access compatible with PHP 5.6 8133a65a1a
    Merge 'gerrit #7174' into stable/master 6906f2a53b
    request #9202 Make phpwiki compatible with php 5.6 9ff88e32e4
    Merge 'gerrit #7176' into stable/master 59bab6b4f2
    request #9202: convert tracker v3, mustache and nusoap to php 5.6 6ac51b50c4
    Merge 'gerrit #7238' into stable/master cb6fd805a4
    request #9202: have a development environment with PHP 5.6 ec66ddad84
    Get rid of old no-extensions-but-php-anyway files 6927ebdd97
    Do not try to be cleaver than PHP Garbage Collector 496b11e9c3
    Complete Nginx configuration 9030d2e569
    Make mediawiki compatible with Nginx + PHP 5.6 e23e1b776d
    Make SOAP compatible with nginx + fpm 114ad8507a
    php launcher v5.6 be66cd90c3
    Remove useless use 99649899ad
    Configure Nginx & FPM in PHP aa1c09c7ad
    Fix various nginx / php 5.6 related issues discovered during 9.5 valid 9fe2ff8532
    Remove register_globals dependency on access log page dbfc2f0cae
    Old extractCross api should have .php extension 82afe5e826
    Fix nginx config for mailman and doc b8c3d0a1c7
    Add php 5.6 dependencies d8cc12fc60
    Automate deployment of nginx/php-fpm conf ff025e2c8f
    Docker tuleap-aio configurtion scripts are part of Tuleap 6e17ef69f8
    setup.sh now install and configure in PHP 5.6 by default b23025c9cb
    Project data export should not rely on register globals to work b76f4a5e1c

    Follow-ups

    User avatar
    Thomas Gerbet (tgerbet)2017-12-04 13:53
    I think we can now close this meta-request about PHP 5.6. All new instances are running PHP 5.6 by default. Remaining issues are bugs that must be fixed but it's not really part of the migration process now that we have live instances using it.

    • Status changed from Under implementation to Closed
    • Close date set to 2017-12-04
    User avatar
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes
    User avatar
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes
    User avatar
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes
    User avatar
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes
    User avatar
    On the PHP 5.6 dev environment, viewvc (SVN core, SVN plugin and I suppose on CVS too) is not working.
    User avatar
    Thomas Gerbet (tgerbet)2016-11-03 15:56
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes
    User avatar
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes
    User avatar
    • Original Submission
      Something went wrong, the follow up content couldn't be loaded
      Only formatting have been changed, you should switch to markup to see the changes