Tuleap Community Edition development and releases are no longer public. You have until September 30th to download packages and sources in Tuleap project. You can contact the team if you need further assistance.

    •  
      request #12146 LDAP Error :PHP message: PHP Notice: Undefined index: mail in /usr/share/tuleap/plugins/ldap
    Infos
    #12146
    Alaney Dória (alaney)
    2018-08-22 20:10
    2018-08-18 04:13
    12831
    Details
    LDAP Error :PHP message: PHP Notice: Undefined index: mail in /usr/share/tuleap/plugins/ldap
    Error on LDAP when user try to login
    ldap_syslog
    2018-08-15T23:00:30+02:00 [14963] [warning] Cannot bind to LDAP server: ***ERROR MESSSAGE:Can't contact LDAP server ***ERROR no:-1
    2018-08-15T23:00:30+02:00 [14963] [warning] Cannot connect to any LDAP server: ***ERROR:Can't contact LDAP server ***ERROR no:-1
    2018-08-15T23:00:34+02:00 [675] [error] Unable to bind to LDAP server: ***ERROR:Can't contact LDAP server ***ERROR no:-1
    2018-08-15T23:00:34+02:00 [675] [warning] Cannot bind to LDAP server: ***ERROR MESSSAGE:Can't contact LDAP server ***ERROR no:-1
    2018-08-15T23:00:34+02:00 [675] [warning] Cannot connect to any LDAP server: ***ERROR:Can't contact LDAP server ***ERROR

    nginx error_log

    2018/08/18 02:34:33 [error] 797#0: *1 FastCGI sent in stderr: "PHP message: PHP Notice: Undefined index: mail in /usr/share/tuleap/plugins/ldap/$
    PHP message: PHP Notice: Undefined index: cn in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 343
    PHP message: PHP Notice: Undefined index: uid in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 344
    PHP message: PHP Notice: Undefined index: eduid in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 345
    PHP message: PHP Notice: Undefined index: uid in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 378
    PHP message: PHP Notice: Undefined index: dn in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 379
    PHP message: PHP Notice: Undefined index: server in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 111
    PHP message: PHP Notice: Undefined index: server in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 202
    PHP message: PHP Notice: Undefined index: server in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 138" while reading response he$
    2018/08/18 02:57:39 [error] 3708#0: *7 FastCGI sent in stderr: "PHP message: PHP Notice: Undefined index: mail in /usr/share/tuleap/plugins/ldap$
    PHP message: PHP Notice: Undefined index: cn in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 343
    PHP message: PHP Notice: Undefined index: uid in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 344
    PHP message: PHP Notice: Undefined index: eduid in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 345
    PHP message: PHP Notice: Undefined index: uid in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 378
    PHP message: PHP Notice: Undefined index: dn in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 379
    PHP message: PHP Notice: Undefined index: server in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 111
    PHP message: PHP Notice: Undefined index: server in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 202
    PHP message: PHP Notice: Undefined index: server in /usr/share/tuleap/plugins/ldap/include/LDAP.class.php on line 138" while reading response he$
    Authentication & LDAP
    10.4
    CentOS 6
    • [ ] enhancement
    • [ ] internal improvement
    Empty
    Stage
    Empty
    Waiting for information
    Empty
    Attachments
    References
    References list is empty

    Follow-ups

    User avatar
    I turned on the log for debug and I can see
    LDAP search success cn=users,cn=accounts,dc=mydomain,dc=local uid=myaccount *** SCOPE: 1 *** ATTRIBUTES: mail, cn, uid, employeeNumber, dn.
    But then I use a username that doesn't exist in my freeipa and the above reply was the same. So this result actually is meaningless :(.

    So finally I found the problem. The problem is with $sys_ldap_eduid that with new version is comming with employeenumber or something. I put uid.
    One last question, how do I get to authenticate to as specific user group??
    User avatar
    I have a news. I noticed that if I put wrong password the ldap_syslog gives the following error
    2018-08-22T18:57:45+02:00 [17920] [error] Unable to bind to LDAP server: ldap://mydomain ***ERROR:Invalid credentials ***ERROR no:49

    But if I put the right password i says nothing but it doesn't authenticate me. So the message above is correct since the password is incorrect. So when I have the user and pass there is no error. I think that this proves maybe that the the server is being called.
    User avatar
    Thomas Gerbet (tgerbet)2018-08-22 08:44
    Can you check if you can read the file with the codendiadm user?

    runuser -l codendiadm -c 'cat /etc/tuleap/plugins/ldap/etc/ldap.inc'
    User avatar
    Thomas Gerbet (tgerbet)2018-08-21 09:12
    For the just does not work with no error of your last follow up: is the plugin activated? Is sys_auth_type set to ldap in the local.inc?

    For the original issue of this request what are the value of sys_ldap_mail, sys_ldap_cn, sys_ldap_uid and sys_ldap_eduid? If possible can you attach your ldap.inc expunged from sensitive values?
    User avatar
    Yes it's a new deployment and the ldap.inc file exists. The content of the file is a backup of a previous installation which I had ldap configured.
    -rw-r--r-- 1 root root 5518 Aug 4 18:51 /etc/tuleap/plugins/ldap/etc/ActiveDirectory.inc
    -rw-r--r-- 1 root root 5504 Aug 4 18:51 /etc/tuleap/plugins/ldap/etc/OpenLDAP.inc
    -rw-r--r-- 1 root root 5219 Aug 17 15:30 /etc/tuleap/plugins/ldap/etc/ldap.inc
    -rw------- 1 root root 5227 Aug 15 22:30 /etc/tuleap/plugins/ldap/etc/ldap.inc.save
    -rw-r--r-- 1 root root 115 Aug 4 18:51 /etc/tuleap/plugins/ldap/etc/logrotate.syslog
    User avatar
    Thomas Gerbet (tgerbet)2018-08-20 08:51
    Hello,

    Is this a new deployment? From your logs I would say the configuration file of the LDAP plugin (/etc/tuleap/plugins/ldap/etc/ldap.inc) is either missing or empty.

    • Status changed from New to Waiting for information