•  
      request #13159 "Full Installation" guide does not work properly on CentOS 7
    Infos
    #13159
    Sean Lanigan (s.lanigan.extel)
    2019-03-29 16:57
    2019-03-27 05:03
    13328
    Details
    "Full Installation" guide does not work properly on CentOS 7
    I am trying to get Tuleap working, in a CentOS 7 virtual machine. I've been following the instructions at https://docs.tuleap.org/installation-guide/full-installation.html but I cannot get the Git plugin to work.

    I can get Tuleap itself to install, but cannot create Git repositories - the web UI just talks about the task being queued (to create a repo), but it never finishes. I haven't tried doing anything complicated or different while doing the initial install - I have exactly followed the steps in the guide, trying to create an all-in-one Tuleap VM (i.e. no separate DB or anything like that), but it does not work properly.


    It seems like something is going wrong with Gitolite. I've been trying a whole bunch of things, and tried from scratch several times, but what seems to be happening is that my CentOS 7 system ends up with `gitolite3` installed, along with system user and group for `gitolite3` - but the install scripts and many other Tuleap parts expect the user/group to be just `gitolite`.


    I believe the documentation and/or the installation scripts need to be updated.



    This is the version info for the CentOS VM:

    root@tuleap ~]# cat /etc/*release*
    CentOS Linux release 7.6.1810 (Core)
    Derived from Red Hat Enterprise Linux 7.6 (Source)
    NAME="CentOS Linux"
    VERSION="7 (Core)"
    ID="centos"
    ID_LIKE="rhel fedora"
    VERSION_ID="7"
    PRETTY_NAME="CentOS Linux 7 (Core)"
    ANSI_COLOR="0;31"
    CPE_NAME="cpe:/o:centos:centos:7"
    HOME_URL="https://www.centos.org/"
    BUG_REPORT_URL="https://bugs.centos.org/"

    CENTOS_MANTISBT_PROJECT="CentOS-7"
    CENTOS_MANTISBT_PROJECT_VERSION="7"
    REDHAT_SUPPORT_PRODUCT="centos"
    REDHAT_SUPPORT_PRODUCT_VERSION="7"

    CentOS Linux release 7.6.1810 (Core)
    CentOS Linux release 7.6.1810 (Core)
    cpe:/o:centos:centos:7
    Empty
    Installation process
    All
    CentOS 7
    Empty
    Stage
    Empty
    Closed
    2019-03-29
    Attachments
    Packages and versions installed by yum
    References

    List of items referenced by or referencing this item.

    Artifact Tracker v5

    Follow-ups

    • User avatar
      • Status changed from Under review to Closed
      • Close date set to 2019-03-29
    • User avatar
      Ah OK, that makes sense - thank you :)
    • User avatar
      Integrated into Tuleap 10.11.99.170

    • User avatar
      Hi,

      I just checked the install script and the message in your trace saying "Start sshd service" should in fact be something like "Please, start the SSHD service to continue". It's far for obvious what's expected from the user in the current situation, gerrit #14523 should solve that.

      The installer for the Git plugin needs the SSH daemon to be up because it will do some setup of gitolite and to prepare communication between Tuleap and gitolite.

      • Status changed from Acknowledged to Under review
      • Reported in version changed from 10.11 to All
    • User avatar
      Hi Thomas,

      Thanks for the pointer, in looking into the sshd service I found that before installing Tuleap in my VM that `openssh-server` was not installed, and hence the service was not running (it is an LXC image, so could explain why it was not running, I would have thought usually SSH would be running on a Linux server).

      I first installed it with `yum install openssh-server`, then restarted it with `systemctl restart sshd.service`, checked it was then actually running, and only then ran the steps on the "Full Installation" page.

      I now see some additional output from the installer:

      ```
      * Successful installation!
      Apache has been configured
      * Adding credentials to /root/.tuleap_passwd
      * Plugin SVN is configured
      Initialized empty Git repository in /var/lib/tuleap/gitolite/repositories/gitolite-admin.git/
      Initialized empty Git repository in /var/lib/tuleap/gitolite/repositories/testing.git/
      WARNING: /var/lib/gitolite/.ssh missing; creating a new one
      (this is normal on a brand new install)
      WARNING: /var/lib/gitolite/.ssh/authorized_keys missing; creating a new one
      (this is normal on a brand new install)
      Cloning into '/var/lib/tuleap/gitolite/admin'...
      remote: Counting objects: 6, done.
      remote: Compressing objects: 100% (4/4), done.
      remote: Total 6 (delta 0), reused 0 (delta 0)
      Receiving objects: 100% (6/6), done.
      * Plugin Git is configured
      ```

      Now when I enable the Git plugin and create repositories it does seem to work correctly. :) The problem seems to have been caused by sshd.


      I see that in my initial attempt, openssh-server did get installed by yum as a dependency - how come the Tuleap installer seems to fail if sshd is not already running? All I needed to do was install and restart it with `systemctl restart sshd.service`.

      Also, I did not need to manually change any paths for Git 2.12 - it seems that the installer handles all this.
    • User avatar
      Hello,

      What's the status of the sshd service?
      Can you check as a site administrator the status of the events in the Git queue?

      • Status changed from New to Acknowledged
    • User avatar
      • Original Submission