•  
      request #13819 The "Available" switch in the Edit service modal does not change
    Infos
    #13819
    Benjamin Dauton (bdauton)
    2019-08-28 17:24
    2019-08-28 15:37
    14662
    Details
    The "Available" switch in the Edit service modal does not change

    Given I am Siteadmin,
    When I edit an existing custom service in any project and I click on the "Available (also available for new projects)" switch, then it looks like it does nothing.
    Actually, it does something. Since the "Add a new service modal" is present on the page and the label and checkbox input had the same HTML id, when I click on the button in the "Edit modal" it actually triggers the switch in the "Add modal".

    Project admin
    11.5
    Empty
    • [ ] enhancement
    • [ ] internal improvement
    Empty
    Stage
    Joris MASSON (jmasson)
    Closed
    2019-08-28
    Attachments
    Empty
    References

    Follow-ups

    • User avatar
      gerrit #15970 integrated into Tuleap 11.5.99.65

      • Status changed from Under review to Closed
      • Connected artifacts
      • Close date set to 2019-08-28
    • User avatar
      Joris MASSON (jmasson)2019-08-28 16:02
      gerrit #15970 is under review

      • Status changed from Under implementation to Under review
    • User avatar
      Joris MASSON (jmasson)2019-08-28 15:59
      • Summary
        -Can't use "Available" switch in new service modal when the icon selector is present 
        +The "Available" switch in the Edit service modal does not change 
      • Original Submission
        Something went wrong, the follow up content couldn't be loaded
        Only formatting have been changed, you should switch to markup to see the changes
      • Status changed from New to Under implementation
      • Assigned to changed from None to Joris MASSON (jmasson)