•  
      request #41860 Rename getDatasetItemOrThrow to getAttributeOrThrow
    Infos
    #41860
    Joris MASSON (jmasson)
    2025-03-25 11:26
    2025-02-20 17:38
    43536
    Details
    Rename getDatasetItemOrThrow to getAttributeOrThrow

    In request #41486, we removed the possibility of passing a camelCase name for a data-attribute in favor of passing the full name of the data-attribute (in kebab-case).

    Since the getDatasetItemOrThrow now only calls element.getAttribute(), it is no longer limited to data-attributes but can be used for any kind of attribute, really. We should rename it.

    Dev tools
    Empty
    Empty
    • [ ] enhancement
    • [x] internal improvement
    Empty
    Stage
    Joris MASSON (jmasson)
    Closed
    2025-03-25
    Attachments
    Empty
    References

    Follow-ups